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Co to sa benchmarki i dlaczego je organizujemy?

Nauka i technika posiada wiele mozliwodci, ktére pozwalaja ocenié skutecznosé oraz wydajnosé metod
naukowych, np. testowanie, walidacja, weryfikacja, ocena, a takze benchmarking. Poczatkujacym na
pewno nie jest tatwo rozrézni¢ te pojecia, ale naprawde kazdy z tych termindéw ma nieco inne
znaczenie. Termin ,benchmark” stat sie ostatnio modny. By¢ moze spotkaliscie sie z benchmarkami
sprzetu komputerowego. Nie ma ogdélnie przyjetej definicji benchmarkingu. Krétko mozna powiedzieé,
ze benchmark oznacza ustalony standard, ktéry pomaga okresli¢ jakosé np. oprogramowania, sprzetu,
jakiejs ustugi, proceséw czy metody naukowej.

Benchmarking to metoda poszukiwania modelowych rozwigzan w celu uzyskania najlepszych
wynikoéw poprzez uczenie sie od innych i korzystanie z ich doswiadczenia. Tu trzeba podkresli¢
najwazniejszy i niezbedny filar benchmarkingu: uczenie sie. Istota benchmarkingu jest przede
wszystkim identyfikacja najlepszych praktyk i ich adaptowanie. Szukamy najlepszych metod
dochodzenia do celu, poréwnujemy wyniki z innymi, identyfikujemy mocne i stabe strony (np. naszej
metody rozwigzania problemu), uczymy sie od innych i doskonalimy nasze praktyki, dzieki czemu
rozwijamy swoje umiejetnosci.

Benchmarki poréwnawcze organizowane sa w wielu dziedzinach nauki i techniki. Podobnie, jak w
naszym przypadku, benchmark moze polega¢ na rozwigzaniu konkretnego zadania przy uzyciu
dowolnych lub wskazanych przez autora benchmarku metod i narzedzi. Uczestniczac w takich
benchmarkach czesto wytapujemy wiasne btedy, ktoérych sami nie zauwazylibysmy, a widzimy je
dopiero, gdy poréwnujemy wyniki z innymi uczestnikami. To wazne, dzieki temu podnosimy jakos¢
naszej pracy, badan, a korygujac btedy, mozemy by¢ pewni, ze nasze wyniki sa prawidtowe. Mozna
poda¢ przyktad z energetyki jadrowej. Miedzynarodowe organizacje, tak jak: Miedzynarodowa
Agencja Energii Atomowej, czy Agencja Energii Jadrowej OECD, organizuja systematycznie
benchmarki, np. dotyczace obliczenn zwiazanych z bezpieczenstwem pracy reaktora jadrowego.
Przedstawiciele wielu krajéw wykonuja okreslone zadanie. Nastepnie poréwnujac wyniki mozemy
sprawdzié¢, czy uczestnicy benchmarku uzywaja wtasciwych kodéw obliczeniowych, na jakim etapie
popetniaja ewentualne btedy i czy ich metoda dochodzenia do wyniku jest prawidtowa. To pozwala
upewnia¢ sie, ze elektrownie jadrowe oraz reaktory badawcze, ktdére pracuja na S$wiecie, sa
kontrolowane na poziomie lokalnym prawidtowo 1 wedtug przyjetych standardéw. To jest
niestychanie istotne, aby$smy wszyscy czuli sie bezpiecznie.

Wy, jako uczestnicy projektu ,Szkolna Radonowa Mapa Polski” zapewne po raz pierwszy w zyciu
wezmiecie udziat w benchmarku poréwnawczym. Moze to by¢ dla Was ciekawe doswiadczenie na
przysztosé. Liczymy na to, ze wiele szkdt, bioracych udziat w projekcie, wykona benchmark i odedle
swoje wyniki. Sprawdzimy, ktére szkoty wykonaja zadanie najlepiej. Pamietajcie tylko, aby trzymac
sie tredci zadania. W benchmarkach nie powinno by¢ mozliwosci na interpretacje polecenia, dlatego
staralismy sie, aby jego tres¢ byta jak najbardziej precyzyjna.

Zyczymy powodzenia!



TRESC BENCHMARKU ,Ocena stezenia radonu”

Benchmark podzielony zostat na dwie, niezalezne od siebie czedci.

CZES¢ 1

Dokonaj analizy zdje¢ mikroskopowych ptytek CR-39 detektoréw radonu przy uzyciu programu
ImageJ, a nastepnie na podstawie ponizszej kalibracji, okredl stezenie radonu w dwoch
pomieszczeniach, w ktérych wykonywany byt pomiar przy uzyciu tych detektoréw. Kazde zdjecie to
osobny detektor, a tym samym inny pomiar, wykonany w dwdéch réznych pomieszczeniach. Ponizsza

kalibracja pozwala na przeliczenie liczby zaobserwowanych §ladow na ptytkach na wartos¢ stezenia
radonu zgodnie z formuta podana w punkcie ,Kalibracja detektora”.

Zdjecia ptytek detektora CR-39 uzytych do pomiaru w dwdch pomieszczeniach:

Pomieszczenie 1 - zdjecie 1, plik: czescl_zdjeciel.jpg
Pomieszczenie 2 - zdjecie 2, plik: czescl zdjecieZ.jpg

Kalibracja detektora:

Krzywa kalibracyjna wykonana na podstawie sladow w ptytce CR-39 ma zaleznos¢ liniowa pomiedzy
stezeniem radonu w jednostkach [Bg/m?®] a gestoscia odczytanych $ladow z ptytki [n/cm?], gdzie n -
liczba sladow na ptytce.
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Tabela Parametry krzywej kalibracyjnej
a b
Krzywa kalibracyjna ma 0,1232 -40,1
postac funkcji liniowej:
y=a-x+ b u(a) u(b)
0,0010 2,9

gdzie x - gestos¢ sladdw, y - stezenie radonu oraz a,b - wspdtczynniki prostej.

W arkuszu kalkulacyjnym radon_benchmark_wynik.xls, w skoroszycie ,Czes$¢ 1" nalezy wprowadzic¢
wyniki dla kazdego zdjecia: liczbe sladdw, obliczong powierzchnie zdjecia, gestosé sladow oraz stezenie
radonu wraz z ich niepewnosciami.



CZES¢ 2

a) Wykonaj kalibracje na podstawie trzech zdje¢ ptytek CR-39, ktérym odpowiadaja znane stezenia
radonu (zamieszczone w ponizszej tabeli). Wykonaj analize tych zdje¢ przy pomocy programu ImageJ.
Krzywa kalibracyjna wykonana na podstawie sladéw na ptytkach CR-39 przyjmuje zaleznosé liniowa
pomiedzy stezeniem radonu w jednostkach [Bg/m?®] a gestoscia §ladéw z ptytki [n/cm?). Parametry
prostej wraz z jej niepewnodciami y=a-x+b mozna wyliczy¢ samodzielnie lub przy uzyciu dowolnego
programu stuzacego do dopasowania prostej do punktéw.

b) Nastepnie wykonaj analize dwdéch zdje¢ z detektoréw CR-39 uzytych do pomiaru stezenia radonu
w dwoch pomieszczeniach przy uzyciu programu ImageJ. Na podstawie kalibracji wykonanej w
punkcie a okreél stezenie radonu w pomieszczeniach, w ktérych wykonywany byt pomiar.

Uwaga: pomiary wykonane w czesci 11 2 benchmarku sq niezalezne, wykonane na innych detektorach, w
innych porach roku i w innych miejscach; informacje o tym, gdzie i kiedy wykonane zostaty te pomiary sq
nieistotne do wykonania zadania.

Dane do wykonania kalibraciji :

Zdjecie ptytek Stezenie radonu Niepewno$¢ stezenia radonu [Bg/m?]
kalibracyjnych [Ba/m3]
kalibracja_zdjeciel.jpg 82,9 4.2
kalibracja_zdjecie2.jpg 203 10
kalibracja_zdjecie3.jpg 489 23

Zdjecia ptytek CR-3%2 uzytych do pomiaru w dwdch pomieszczeniach:

Pomieszczenie 1 - zdjecie 3, plik: czesc2_zdjecie3.jpg
Pomieszczenie 2 - zdjecie 4, plik: czesc2_zdjecie4.jpg

W arkuszu kalkulacyjnym radon_benchmark_wynik.xls, w skoroszycie ,Czes¢ 2" nalezy wprowadzic¢
wyniki:

e kalibracji - dla kazdego zdjecia kalibracyjnego: liczbe sladéw, obliczone pole powierzchni
zdjecia, gestos¢ sladow oraz parametry prostej y=a-x+b: a, b. Wszystkie wielkosci nalezy podac
wraz z niepewnosciami,

e pomiaru stezenia radonu w dwdch pomieszczeniach, tj. dla kazdego zdjecia: liczbe Sladdw,
obliczona powierzchnie zdjecia, gestos¢ sladéw oraz stezenie radonu wraz z niepewnosciami.

Wazna informacja do czedcili 2:

e Pamietaj, aby wszystkie wielkosci oraz wspdtczynniki krzywej kalibracji obliczy¢ wraz z ich
niepewnosciami. Wszystkie niezbedne wzory podane zostaty w czesci: INSTRUKCJA
WYKONANIA ANALIZY PRZY UZYCIU PROGRAMU ImageJ.

e W czedci 2w celu dopasowania prostej y=a-x+b do danych: x - gestosé sladow, y - stezenie radonu,
nalezy uwzglednic takze niepewnosci x i y.



Sugerowana kolejnos¢ wykonania analizy kazdego zdjecia ptytki:
a. weczytanie zdjecia,
b. wybranie sladéw do analizy poprzez odpowiednie natozenie filtru na zdjecie,
c. oszacowanie rozmiaréw sladdéw, ktére maja by¢ brane pod uwage w analizie,
d. analiza liczby sladéw,
e. o0szacowanie rozmiaru analizowanego obszaru - wyznaczenie pola powierzchni,
f.  obliczenie gestosci sladow.

ISTOTNE UWAGI I KOMENTARZE:

e Proponujemy, aby zadanie wykonywaty grupy uczniow, jako projekt zespotowy.

e Szkotfa bioraca udziat w benchmarku moze wysta¢ wiecej niz jeden arkusz kalkulacyjny z
wynikami, o ile zadanie wykonywaty niezalezne grupy uczniow (osobno, bez wzajemnej
konsultacji).

e Prosimy NIE ZMIENIAC nazwy wypelnionego arkusza kalkulacyjnego oraz nazwy
skoroszytow.

e Prosimy NIE ZMIENIAC FORMATOWANIA skoroszytow, nie zmienia¢ polozenia
komorek, tylko wprowadzi¢ wartosci w odpowiednie pola.

o W przypadku pytan, prosimy o kontakt: radon@forumatomowe.org.

NIEPRZEKRACZALNY TERMIN NADSYEANIA WYNIKOW: 5 marca 2021 roku
WYNIKI PROSIMY NADSYEAC NA ADRES: radon@forumatomowe.org



INSTRUKCJA WYKONANIA ANALIZY PRZY UZYCIU PROGRAMU ImageJ

Ponizej znajduje sie instrukcja, ktéra pozwoli zaznajomi¢ sie z programem Image]J i przeprowadzi¢
analize obrazéw spod mikroskopu. Zyczymy mitej 1 owocnej pracy!

Przyijeto nastepujace oznaczenia:

n-

liczba sladéw na plytce

u(n) - niepewnosc liczby sladéw na plytce

S -

powierzchnia ptytki

u(S) - niepewnosc powierzchni ptytki

p-

gestosc sladéw na ptytce

u(p) - niepewnosc gestosci sladow na ptytce

1. Program Image]

Image] to darmowy program stuzacy do przeprowadzania analizy obrazéw. Oprogramowanie to
zostato napisane w jezyku Java przez pracownikéw amerykanskiego Narodowego Instytutu Zdrowia
(National Institute of Health, NIH). Uzywanie ImageJ nie wymaga umiejetnosci programowania,
jednakze dla zaawansowanych uzytkownikéw istnieje mozliwosé zarowno tworzenia makro-polecen,
jak i pisania autorskich programow. W naszym projekcie nie bedzie to wymagane.

Image] umozliwia:

wezytywanie wielu rodzajow plikow, jak JPG, PNG, GIF, TIFF, BMP czy medyczne obrazy
zapisane jako DICOM,

analize obrazéw zaréwno czarno-biatych, jak i kolorowych,

mozliwos¢ powiekszania obrazu do 32 razy

odczytywanie podstawowych parametrow piksela (jego wartos¢ w obrazie czarno-biatym
lub liczby opisujace jego kolor w systemie RGB (Red, Green, Blue)) lub zaznaczonego
obszaru pikseli, w tym zwracanie statystyk na temat obszaru: minimalna, maksymalna
1 $rednia wartos¢ pikseli w tym obszarze, wraz z informacja o rozrzucie tej sredniej,
podstawowe operacje na obrazie jak przycinanie, obracanie, rysowanie, rozdzielanie
obrazu na kolory sktadowe, manipulowanie kontrastem czy balansem bieli, takze bardziej
zaawansowane jak wygtadzanie lub wyostrzanie,

wykorzystanie wtyczek (plugins) tworzonych przez innych autoréw, miedzy innymi
dedykowanych specjalistycznym zastosowaniom (analiza zdje¢ astronomicznych,
mikroskopowych, odnajdywanie wzorcéw w obrazie etc),

przeprowadzanie analiz z oszatamiajaca szybkoscia 40 miliondow pikseli na sekunde,

1 wiele innych.

Aby rozpoczac prace z programem nalezy odwiedzi¢ ponizsza strone internetowa:

https://imagej.nih.gov/ij/index.html

1 Podajemy te informacje jako dodatkowe ciekawostki dla najbardziej zainteresowanych uczniéw - dysponujac
plikiem ze swoimi badaniami obrazowymi {np. rentgen, USG, tomografia komputerowa, rezonans magnetyczny)

moga przegladac je za pomoca omawianego programu


https://imagej.nih.gov/ij/index.html

home | news | docs | download | plugins | resources | list | links

ImageJ | | Search

Image Processing and Analysis in Java

o Features

o News

o Documentation

o Download

o Run in Chrome or Firefox Hew
o Plugins

o Developer Resources

o Mailing List

o Links

Support 1s available on the mailing list and on the image sc
forum. Disclaimer

Mozemy skorzysta¢ z jednej z dwdéch opcji: ,Download”, czyli pobranie pliku na dysk komputera -
wtedy nalezy wybrac pliki adekwatne do systemu operacyjnego na komputerze (prawdopodobnie u
wiekszosci uzytkownikéw bedzie to Windows, maty plik okoto 70MB) - te opcje rekomendujemy:

home | news | docs | download | plugins | resources | list | links

Download

Platform Independent

To install Image] on a computer with Java pre-installed, or to upgrade to the latest full
distribution (including macros, plugins and LUTs), download the ZIP archive (6MB)
and extract the Image] directory. Use the Help> Update ImageJ command to upgrade
to newer versions.

Mac OS X

Download ImageJ bundled with Java 1.8.0 172 (may need to work around Path
Randomization). Instructions.

Linux
Download ImageJ bundled with Java 1.8.0_172 (82MB). Instructions.

Windows
Download ImageJ bundled with 64-bit Java 1.8.0_172(70MB). Instructions.

Documentation

Tiago Ferreira's comprehensive Image] User Guide is available as an 8MB PDF
document and as a ZIP archive. The online JavaDoc APT documentation 1s also
available as a ZIP archive.

Source Code
The Image] Java source consists of 132000 lines of code in 348 files. It is available

online and as zip archives.

Example Images
31 downloadable sample images and stacks are available in Imagel's File>Open
Samples submenu. These images, and more, are also available as a 8 2MB zip archive.

You can also browse the Image] download directory at imagej nih gov/ij/download/. Newer Imagel
distributions are available at http://wsr.image) net/distros/. Refer to the release notes for a list of
new features and bug fixes.

top | home | news | docs | download | plugins | resources | list | links

Opcja druga to wybdr ,Run in Chrome or Firefox”, czyli witaczenie programu bezposrednio
w przegladarce internetowej. W tym wypadku mozna réwniez bezposrednio odwiedzi¢ strone
https://ij.imjoy.io/ :



https://ij.imjoy.io/
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Niezaleznie od sposobu uruchomienia programu (z dysku lub w przegladarce), jego dziatanie jest
identyczne, chociaz w oknie przegladarki moga czasem wystepowacé¢ drobne problemy- pojawi sie
okno jak ponizej:

¥ ImageJ = O ﬁﬁ

File Edit Image Process Analyze Plugins Window Help
B olc|o|<| 4]+ |\ A| o]~ gl4|al7] |»

ImageJ 1.28e / Java 1.5.0_09

Dev | Stk |LUT

2. Przebieg przykladowej analizy zdjecia mikroskopowego

Na wstepie ogdlne zapoznajmy sie z dostepnym menu programu - oto funkcje kolejnych pél w gérnym

rzedzie:
¥ ImageJ = O ﬁﬁ

File Edit Image Process Analyze Plugins Window Help
B olc|o|<| 4]+ |\ A| o]~ gl4|al7] |»

ImageJ 1.28e / Java 1.5.0_09

Dev | Stk |LUT

e File:wczytywanie i zapisywanie obrazow, w tym wczytywanie obrazéw z biblioteki programu
(np. obrazy anatomiczne, z mikroskopu optycznego, serie ukazujaca mitoze itd.)

e Edit: cofanie polecenia, wklejanie, wycinanie, czyszczenie zaznaczenia

e Image: zmiana typu obrazu, operacje zwiazane z jasnoscia, kontrastem, balansem bieli,
sktadaniem i rozktadaniem na sktadowe obrazéw kolorowych

e Process: procesowanie obrazka, jak mnakitadanie filtrow (np. wyostrzajacych lub
zmiekczajacych), znajdowanie krawedzi na obrazie, operacje matematyczne jak dodawanie
czy odejmowanie wartosci pikseli, transformaty obrazu

e Analyze: mozliwo$¢ wykonania pomiaru parametréw zaznaczonego obszaru, takze
analizowanie wynikéw pomiaru jak wykonywanie ich podsumowan statystycznych,
histograméw, takze skalowanie obrazu (aby z pikseli przej$¢ np. na centymetry)

e Plugins: korzystanie z dodatkowych programoéw, np. utatwiajacych zliczanie punktéw na
obrazie (po kliknieciu myszka na obrazie zostaje w tym punkcie numerowany znacznik)



e Window: ustawienia okna, przy wiekszej liczbie otwartych plikéw przyktadowo mozna je
uporzadkowac jeden za drugim
e Help: pomoc, linki do forum uzytkownikow, instrukcji oraz przykiady uzycia réznych funkcji

Lista ikon ponizej tekstu to narzedzia do pracy z obrazem: pierwsze cztery to opcje wyboru ksztattu
zaznaczenia (prostokat, owal, linia tamana, linia dowolna), rysowanie linii prostej, pomiar kata,
zaznaczenie punktéw, ,rozdzka” utatwiajaca pol-automatyczny wybdr obszaru, mozliwos¢ dodania
tekstu, powiekszenie obrazu, przesuwanie obrazu, prébkowanie koloru. Dalsze dwie ikony utatwiaja
prace programistyczna, dalej mamy pedzel do rysowania na obrazie, farbe do zmiany koloru catego
obszaru zaznaczenia, mozliwo$¢ rysowania strzatek oraz narzedzie rysowania profili liniowych.

2.1. Wczytanie obrazu

Polecenie File -> Open -> wybieramy z okna dialogowego plik lub pliki, ktére chcemy analizowac:

- X
[ Edit Image Process Analyze Plugins Window Help
new |Ala]er|C]] ofsuf 4] 2] 2] 2] &>
elections (right click to switch)
Open Next Ctrl+Shift+O
Open Samples

Open Recent
Import

Close Ciri+W

Close Al Ctrl+Shift+W
Save Ctri+S
Save As

Revert Ctr+R.

Page Setup...
Print__. Ctri+P

Quit

Analizowany obraz zostanie otwarty w nowym oknie:

25020 44 piata ROB, 19WE




2.2. Reczne liczenie §ladéw

Z gbérnego menu wybieramy narzedzie ,Multi-point” - klikajac na obraz w danych punktach bedziemy
wprowadzac znaczniki, zliczajac oraz upewniajac sie, ze nie liczymy zadnego punktu dwukrotnie:

4
File Edit Image Process Analyze Plugins Window Help

glojc|o| <4l N Al 0|0 /20| 2] s8>

2.3. Automatyczne liczenie sladéw

Przy duzej liczbie sladdw liczenie reczne moze by¢ bardzo zmudne, co wiecej dostajemy tylko
informacje o liczbie sladow, ale juz nie o ich ksztalcie czy rozmiarze. Aby uzyskac taka petniejsza
informacje, postuzymy sie poleceniem Analyze -> Analyze Particles...

4 Image X

File Edit Image Process Plugins Window Help
8 oz ~|£ ] e Ctrl+M i-,,é’|®|ﬁ'|ﬁ|@l|>>

“Multi-point™ or point (right click to

Summarize
Distribution...
Label

Clear Results

Set Measurements...

Set Scale...

Calibrate...

Histogram Ctrl+H
Plot Profile Ctri+K
Surface Plot...

Gels

Tools

Jesli wezytany przez nas obraz byt obrazem kolorowym, otrzymamy nastepujacy komunikat:

4 Particle Analyzer >

RGB images must be threshaolded using
Image=Adjust=Caolor Threshald.




Oznacza on, ze analizy nie mozna wykona¢ na takim rodzaju obrazu, najpierw trzeba wykonac
operacje wskazana pod opcja Image -> Adjust -> Color Treshold (w niektérych przypadkach, kiedy
Color Treshold jest nieaktywny i nie pozwala wykonac filtrowania nalezy wybrac¢ opcje Threshold):

¢ Imagel
File Edit

[=l=

Type ' ”ﬂ b

Process Analyze Plugins Window Help
w4]e]|7]0]&)>

X

Show Info_. Ctri+l | Window/Level. .
Properties. .. Ctri+Shift+P | Color Balance...
Color v\ Thresheld...

Freehand sel X
Brightness/Contrast... Ctrl+Shift+C

Ctrl+Shift+T

Stacks 4| Color Threshold... I

Zoom

Qverlay

Lookup Tables

Operacja ta zamieni obraz na dwukolorowy - czarno-biaty -
tworzac mape punktéw, ktérych warto$é znalazia sie
powyzej lub ponizej ustawionego przez uzytkownika progu
(treshold). To najtrudniejszy moment przy automatycznej
analizie, poniewaz od doboru parametréw progu zalezy
skutecznos¢ odciecia tta obrazu i uwypuklenia elementow,
ktorych poszukujemy.

Uzytkownik ma wiele opcji do wyboru - na przyktad polegaé
na odcinaniu konkretnych koloréw (RGB, czerwony, zielony,
niebieski), lub konkretnych barw oraz ich jasnosci
inasycenia (HSB, Hue, Saturation, Brightness). Jesli zdjecie
jest wyrazne, oswietlenie tta jednorodne, a poszukiwane
elementy wyraznie odcinaja sie od tia, ten etap odbedzie sie
bez zadnych probleméw. W przeciwnym wypadku nalezy
poswieci¢ czas na znalezienie (czasem metoda prob i btedow)
optymalnego ustawienia suwakow.

To, czy w poprawny sposdb dokonujemy odciecia widaé
golym okiem na masce natozonej na obraz - ruszajac
suwakami bedziemy widzie¢ jak zmienia sie zaznaczony
obszar, od skrajnosci wyboru wszystkiego (suwaki
rozsuniete szeroko) do skrajnosci nie wybrania niczego
(zakresy suwakow sa zbyt waskie).

Po przeprowadzeniu tej operacji mozemy wrdéci¢ do opcji
Analyze -> Analyze Particles:

10-

Hyperstacks v Size...

Crop Cll+shiftex | CANVas Size-..

Duplicate..  Cirl+Shift+p | e Width-..
Coordinates...

Rename...

Scale... Ctrl+E | Auto Threshaold...

Transform ' Auto Local Threshold...

4 Threshold

Color

Hue

Brightness

Thresholding method:  |Default i I

4

L

Threshold color: |Red vl
Color space: m

Original

™ Dark background

Filtered

Select

Sample |

Stack

Macro

Help

¥ Pass

Ik

¥ Pass
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4 Analyze Particles >

Size (pixel*2):
| circularity. [0.00-1.00

[ Show: [:}uﬂinas LI

—

¥ Display results [ Exclude on edges
[” Clearresults [ Include holes

W Summarize [~ Record starts

[~ Addto Manager [ In situ Show

—

| oK | Cancel | Help |

Program bedzie probowat dopasowac elipsy do elementéw obrazu - dwa parametry liczbowe, o ktore
jestesmy pytanie to kolejno zakres rozmiaru elipsy (tutaj mozemy wpisac¢ zakresy pdl zaznaczonych
obiektow w pixelach do kwadratu, na podstawie ktérych slady zostang automatycznie zliczone) oraz
zakres jej krzywizny (1 oznacza okrag, O linie prosta, liczby pomiedzy elipse). Rozmiar otworu
powstajacego w detektorach sladowych zalezy przede wszystkim od parametréw wytrawiania ptytki
oraz - jesli obraz jest nieskalibrowany, czyli dtugosé podawana jest w pikselach, a nie mm czy cm - od
powiekszenia mikroskopu (ten sam otwér bedzie zajmowat wiecej pikseli na wiekszym powiekszeniu.
Lista wyboru (Show) decyduje jaki obraz zostanie wyswietlony po wykonaniu analizy - opcja Outline
pokaze nam obrysy znalezionych okregdw.

Jesli znalezionych punktéw jest za duzo, musimy zawezic¢ kryteria poszukiwania, narzucajac warunki
na rozmiar otworu. Pojedyncze piksele to niepozadane artefakty, a bardzo duze wartosci to np. wiele
otwordéw zlanych w jeden i potraktowanych jako catos¢ lub inny duzy artefakt, jak ciern w rogu zdjecia.
Aby ustali¢ przecietny rozmiar otworu, nalezy powiekszy¢ zdjecie skrolujac myszka przytrzymujac
przycisk control lub uzy¢ narzedzia lupy - nastepnie wybieramy narzedzie liniowe i rysujemy
kilkukrotnie linie wzdtuz i w poprzek reprezentatywnego $ladu (lub powtarzamy te operacje dla kilku
$ladéw). Srednice odczytujemy z menu gléwnego i na tej podstawie podajemy zakres pél w rubryce
Size (pixel*2) widocznym na powyzszym zdjeciu). Sprawdzenie rozmiaru wykonujemy jak ponizej:

4 Image)
File Edit Image Process Analyze Plugins Window Help

Ojo|z|ofE £\ Al |o|| oy | 45| 7|0 &)

x=2200, y=574, angle=2.4. , length=30.70
I S————
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W uzytym przyktadzie $rednica d wynosi okoto 30 pikseli. Zatem powierzchnia:

d\* 30px\?
= —_ = ~ 2
S—n(z) n( > ) = 711px

Przyjmujac, Ze niepewnos¢ pomiaru srednicy u(d) jest rzedu dwoch pikseli (mozna ja takze wyznaczy¢
powtarzajac kilkukrotnie pomiar $rednicy w réznych kierunkach), otrzymamy nastepujaca
niepewnos¢ wyznaczenia powyzszego pola sladu:

2d d 30px
u(s) = nTu(d) = nzu(d) = HTZPJC ~ 94px?

Zatem analizowany obszar ma powierzchnie 711(94)px? czyli w zakresie 617-805px* z 68%
przedziatem ufnosci®.

Powyzsze wzory maja zastosowanie do zdjec¢ o ksztatcie kota, natomiast powierzchnie prostokatnego
zdjecia obliczamy z prostego wzoru na pole powierzchni prostokata, a jej niepewnos¢ zaleznosci:

u(s) = J(k u(D)® + (- uk))?
gdzie k i1 to dtugosci bokdéw prostokata, a u(k) i u(l) ich niepewnosci. Przyjmijmy, ze u(k) = u(l) = 2 px.

Jesli zatem zawezimy poszukiwania do obszaréw o powierzchni 350-1400 pikseli kwadratowych,
bedziemy uznawaé za poprawne Slady o potowe wieksze i mniejsze niz wskazany. Po wykonaniu
analizy nalezy krytycznie oceni¢ czy ustawiony zakres wyszukiwania nie byt zbyt rygorystyczny
(odrzucalismy poprawne zliczenia) lub za mato rygorystyczny (akceptowalismy btedne zliczenia) -
mozna wyznaczy¢ go empirycznie po kilku prébach. Po ustawieniu parametrow i wykonaniu
automatycznego zliczania otrzymamy tabele z wynikami oraz rysunek pokazujacy dopasowane
ksztatty - w powiekszeniu widzimy, ze kazdemu dopasowanemu obszarowi przypisany jest numer:

L—
4 [u}
25021944 pixels; B-hit, 4.8MB

[ 1 o
C9 |

4
O [ File Edit Font Results
@ |[area [Mean  [StdDev | =
42 465 94634 31.008
143 285 125789 12639
‘Haa 508 92608 30206
Y45 341 110475 25414
| 46 490 99902 29629
47 676 95469 20064
48 412 126529 13515
@ 43 528 96.167  30.682
|50 1977 109689 27.649
F51 380 116.139 19.197

‘ [

Chcac dokona¢ wyznaczenia wiekszej liczby parametrow mozemy wybrac¢ z menu Analyze -> Set
Measurements... wielkosci wskazana w pojawiajacym sie panelu:

2 Obliczanie niepewnosci pomiarowych znajduje siec w podstawie programowej z fizyki, jednak nie precyzuje
poziomu zaawansowania tego tematu - ucznidéw zainteresowanych szczegétami zwiazanymi z obliczaniem
niepewnosci pomiarowych odsytamy do publikacji Wydziatu Fizyki Politechniki Warszawskiej:

http://www.if pw.edu.pl/~labfizlp/cmsimple2 4/linstrukcje pdf/ONP%20-%20poradnik.pdf
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4 Imagel X
File Edit Image Process m@ Plugins Window Help 4 Set Meaturements
Eov|C(|U|/_A_ﬂt Measure Ctrl+M ",|;§"®|/"|ﬁ|@l|»
- ¥ Area W Mean grayvalue
kS s S ORIl e Analyze Particles... [v Standard deviation [~ Modal gray value
Summarize [¥ Min & max grayvalue [~ Centroid
Distribution. . [~ Center of mass v Perimeter
™ Bounding rectangle [~ Fitellipse
Label
[¥ Shape descriptors [~ Feret's diameter
Clear Results [ Integrated density [~ Median
[~ Skewness I~ Kurtosis
[~ Areafraction ™ Stack position

Set Scale...

Calibrate...

Ctrl+H
Ctrl+K

Histogram
Plot Profile
Surface Flot...
Gels

Tools

[™ Limit to threshold

I Display label

[ InvertY coordinates | Scientific notation
[~ Addto overlay [~ NaN empty cells

Redirectto: [None |

Decimal places (0-9) |3

oK | cancel He\pl

Ponizej zamieszczamy ich thumaczenia:

N 5 . . Fe-Area ¥ Mean gray value
Area - pole powierzchni < el

: : : v _Jie"E max grayvalue [ Centroid

. . [ Canter of mass ¥ Parimeter
Standard deviation — odchyléenie standardowe EE I T R

. . : . . e fescriptors [~ Ferefs diameter

: : . . : Integrated density [ Median

- Skewness I™ Kurtosis:

Min & max gray value — minimalna i maksymalna wart memai e

I Uimitto threshold I~ Display label
I Invert ¥ coordinales [~ Scienific notation
- o Addtorovertay - - " Nattemplycelis - - -

Redirectto: [Hone <]

Decimal places (0-9): ,3_

~Mean gray value — Srednia warto$¢ pixela -

Perimeter - obwadd

Po kliknieciu OK wyswietla sie plik Results ze wszystkimi parametrami, ktére zaznaczyliSmy, przy
czym w pierwszej kolumnie widoczna jest liczba znalezionych sladéw. Otrzymane wyniki mozemy
skopiowac¢ bezposrednio do arkusza kalkulacyjnego lub komenda File->Save As... zapisa¢ w pliku.
Zaznaczanie sladéw i analize czastek mozna wykonywac¢ dowolna liczbe razy, w zaleznosci od
potrzeb. Za kazdym razem nalezy jednak zamykac¢ okno Results, poniewaz wyniki sie dodaja.

2.4. Skalowanie obrazu

Do tej pory rozmiary analizowanych obiektow wyrazane byty w liczbie pikseli - mozemy jednak obraz
wyskalowac, aby wiedzie¢ np. ile milimetréw przypada na jeden piksel i podawac wielkos¢ w sposéb
absolutny, a nie wzgledny. Ta operacja jest potrzebna do wyznaczenia pola powierzchni
analizowanego obrazu, a nastepnie obliczenia gestosci sladow, czyli liczby sladéw na jednostke
powierzchni. W celu przeskalowania jednostek potrzebny jest obiekt widoczny na ponizszym zdjeciu
(zdjecie o nazwie ,Skalowanie”), ktérego rozmiar znamy. Odlegto$¢ pomiedzy duzymi pionowymi
kreskami to 10 mikrometréw (0,01mm):
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Aby pomiary wykonywane byty w odpowiedniej skali wykonujemy nastepujaca operacje: wybieramy
narzedzie rysowania linii, rysujemy linie o znanej dtugosci (np. pomiedzy liczba kresek), nastepnie
wybieramy z gérnego menu Analyze->Set Scale...

“ Window  Help ¢ Set Scale
Measure

Analyze Particles o
Distance in pixels: |59 1555

Summarize

Distribution Known distarice

Label e
Pixel aspedt ratio
Clear Result

Set Measurement Jnit of fength

Program automatycznie zmierzyt diugosé linii - nam pozostaje wpisanie rzeczywistego dystansu
(Known distance) i wyboru w jakich jednostkach ma by¢ wyswietlany wynik, gdzie mm to milimetry,
a um to mikrometry. Po kliknieciu ,OK” program przy pomiarach bedzie automatycznie uwzgledniat
skalowanie, np. podajac dtugos¢ w mikrometrach a pole w mikrometrach kwadratowych. Operacje te
nalezy przeprowadzi¢ po wczedniejszej analizie liczby sladdw, gdzie zakres pdl podawany byt tylko w
pixelach.

3. Analiza wynikow

Powyzsza procedura pozwala na przeanalizowanie obrazu bedacego powiekszonym fragmentem
jednej ptytki pomiarowej. W warunkach laboratoryjnych, gdzie analiza dokonuje si¢ automatycznie,
kazdej ptytce wykonywanych jest od kilkudziesieciu do kilkuset zdje¢, a wszystkie wyniki trafiaja
w jeden arkusz. Niemniej posta¢ danych jest analogiczna, jedynie przy jednym zdjeciu jest ich mniej.

Parametrem, ktory chcemy wyznaczy¢ jest gestos¢ sladow, czyli srednia liczba sladéw przypadajaca
na pole powierzchni - poniewaz ten parametr nie bedzie zalezat ani od powiekszenia obiektywu, ani
od wykonanej liczby zdje¢ (jedynie zmniejszaé sie bedzie niepewnos¢ wyznaczenia tego parametru).

Majac przeprowadzane automatyczne zliczanie oraz skalowanie, mozemy podac¢ gestos¢ sladow
dzielac liczbe $ladow n przez pole powierzchni analizowanego obrazka w cm?, otrzymujac n/cm?. Przy
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braku skalowania mozna postugiwacé sie polem wyrazonym w pikselach, pamietajac, ze wymaga to
zachowania identycznych warunkéw odczytu. Wymagamy jednak przeliczenia pikseli na centymetry
- pamietaj, ze przeliczyé nalezy pole powierzchni zdjecia oraz jej niepewnosc.

Znajac liczbe sladow n oraz powierzchnie zdjecia S mozemy obliczy¢ gestosé sladdow p z prostej
zaleznosci:

NI

oraz niepewnos¢ tej wielkodci:

u(p) = J (A9 4 (Lucs))’

Zaktadamy, ze doktadnos¢ wyznaczenia liczby sladéw n wynosi 5%, Zatem:
u(n) =0,05'n

Gdy znasz juz gestosce sladow p, mozesz odczytac stezenie radonu z krzywej kalibracji, ktéra ma postac
funkcji liniowe;:

y=ax+b

gdzie aib to parametry prostej, x - gestos¢ sladow, a y - stezenie radonu. Niepewnos¢ stezenia radonu
u(y) mozna obliczy¢ z prostego wzoru:

u®) = /(xu(@)? + (u(b))?

gdzie u(a) i u(b) to niepewnosci odpowiednio parametru aib.
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